DXX-Rebirth refuses to start on Windows 10
#1
I have tried this with both the current version and the experimental build, everytime I start the game up it crashes just before loading a level. I'm using the latest AMD drivers for my R9 290 card. Is there any way to get the game to start again? I have tried using an opengl32.dll posted in another thread, it gets the game working but it will only run at 9FPS that way.
Reply
#2
Post this in bugs. You might get a better response.
Reply
#3
Alright, I'll do that then
Reply
#4
Please post the register context and stack trace at the time of the crash in a 0.58.1 build.
Reply
#5
(07-12-2016, 01:37 AM)Kp link Wrote:Please post the register context and stack trace at the time of the crash in a 0.58.1 build.

How would I get that information when running the game?
Reply
#6
You do not.  Your OS should provide you with all the crash details.  I think Windows hides lots of it off in one of the Event Logs - or at least, older versions of Windows did.  A Google search for Windows 10 crash log suggests Windows 10 Crash Logs Secrets: How to Find Crash Logs on Windows 10.  None of my systems run Windows 10, so I cannot verify whether this will work for you.
Reply
#7
I have the same issue.

Windows 10 x64 bit
Nvidia GTX 1080

There is nothing in stderr.txt nor stdout.txt. Launching from a command line, there is no output. It just never really launches. Turning on options for -debug -verbose and even -safelog do nothing.

Neither d1x-rebirth.exe nor d2x-rebirth.exe will launch. Compatibility options in Windows 10 don't help either.

Threads here:

https://forum.dxx-rebirth.com/archive/in...d-877.html

and here:

https://www.mtbs3d.com/phpbb/viewtopic.php?f=3&t=14979

Suggest you may need a replacement opengl32.dll file in the folder, but neither work. And I have a device with working OpenGL (Nvidia GTX 1080 with the latest drivers)

But even the NoGL versions (d1x-rebirth-nogl) won't launch, so it doesn't appear to have to do with OpenGL.

This is what appears in the Windows Event Viewer:

Faulting application name: d1x-rebirth.exe, version: 0.0.0.0, time stamp: 0x5ad29161
Faulting module name: ntdll.dll, version: 10.0.17754.1, time stamp: 0xcee84e63
Exception code: 0xc0000005
Fault offset: 0x0004f1e5
Faulting process id: 0xa794
Faulting application start time: 0x01d44e2b8914dff8
Faulting application path: D:\Games\D1X-Rebirth\d1x-rebirth.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: f8874862-b2e4-4eab-a92b-6240c46a87fe
Faulting package full name:
Faulting package-relative application ID:
Reply
#8
You do not have the same issue. The original reporter gets a crash trying to enter a level. You get a crash before you even reach the main menu. I'll address the rest of the problem in the separate thread you opened here (and cross-post that response to the issue you opened on Github). There's no need to post so many places. I read them all.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)