[d2x 0.58.1] Boss robot AI routines randomly fail to load
#1
This is a weird problem, and I've been experiencing it for a while.

I have a problem wherein boss robots' AI routines fail to load properly when entering their room. This manifests in the boss:

- Not emitting its perpetual sound
- Not teleporting
- Not spawning robots when hit

The bosses tend to cloak every once in a while, but it doesn't lead to teleportation - they just decloak after a brief moment and continue sitting in place. They utter their cry in intervals, just like any other robot does, instead of doing it perpetually. Plasma bomblets are emitted normally when shot.

I've had this issue both with original game files and modified ones (Descent.HAM specifically, for altered robot stats), and I've also had the bosses behave properly with both sets of files, so I don't think the issue is on the side of the HAM file.

Funny thing is, this issue occurs randomly - or at least starts occurring at a random point before which everything was fine. Sometimes the issue fixes itself after some time has elapsed, but more often than not the bosses simply sit there and move around, as little as they do. Right now, I'm experiencing this issue in a set of test levels meant for testing the boss robots for the D1,5 campaign.

I used to think that this problem was dependent on the difficulty played, as I almost always encountered the problem on Insane, but less often on Ace and lower, but now I just think it's perfectly random - not enough data to get a conclusive answer. Anyway, I'm attaching a demo file showing a battle with the Red Fatty boss in one of these test levels which demonstrates the issue. At first the AI routine is not loaded and the boss behaves like I described, then after a while it kicks in and the boss starts teleporting, spawning bots when hit and making a perpetual sound.

The demo.
I'm Xfing from Descent BB.net.

D1,5 in progress. Drop by here to find out more.
Reply
#2
As a testament to the occurence's randomness, I tried out the modified D1 final boss afterwards and guess what, his AI routine loaded practically right off the bat. He teleports, makes his trademark sound and I'm sure he would have spawned some robots had I hit him with kinetic weapons (he's modified to only be vulnerable to energy-based fire).

The problem with this whole issue is the randomness - sometimes it can utterly ruin your playing experience by practically neutering the boss. Since this particular boss for example is set not to move around on its own (to mimic the original game), if the AI doesn't load, you can simply fire from a spot far enough from him that he won't react and he'll be a sitting duck, while all you're gonna need is the patience (and energy) to take him down. Not much skill involved that way.

Demo download
I'm Xfing from Descent BB.net.

D1,5 in progress. Drop by here to find out more.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)