VSync not working
#1
Hello. I've been a fan of Descent title since i first played it on 1996 or so when i was in elementary school (Big Grin Big Grin) I've found this VERY NEAT mod of DXX Rebirth. Now I'm attracted back to this game amiddle of high-rigging 3D modern games which requires tons towering specification of hardware.

By the way, I need to limit the fps to 60 as I love my hardware and doesn't want the graphic card to get burnt because of overheating, so I have turned VSync ON on the Options menu, but the FPS still goes waaaay to the 200 fps. This caused my laptop to heaten up quickly. So it has no effect whether I turned vsync on or off it still goes to 200fps. I have tried these steps to turn VSync ON:
[Image: d1x-rebirth2014-10-1321-31-53-36.jpg]


1. I have turned Force VSync ON on my video card control panel (Intel HD 3000) but it still have no effect and the frames per second still goes to 200.

[Image: IntelControlPanel.jpg]


2. I have downloaded D3DOverrider and put D1x-Rebirth to the list and Force VSync ON on D3Doverrider but still no effect. The frame per second still goes to 200 despite I also have turned On the option number 1).
[Image: D3dOverrider.jpg]

3. I have removed semicolon on d1x-rebirth.ini so now it reads:
System Options:

;-nonicefps                    Don't free CPU-cycles
-maxfps 60                    Set maximum framerate to <n> (default: 200, availble: 1-200)
;-hogdir <s>                  set shared data directory to <s>
;-nohogdir                    don't try to use shared data directory

but I still got 200 fps.
[Image: D1XiniConfig.jpg]


4. I have put a shortcut to d1x rebirth and put -maxfps 60 in the end of it but still no work.
[Image: ShortcutParameter.jpg]

Does anyone have any idea to turn VSync On, or at least for me to get 60 fps?

[Image: d1x-rebirth2014-10-1321-31-53-36.jpg]
Reply
#2
Descent rebirth is overheating your laptop??  :o
If that is the case then I suggest cleaning maintenance.
Vsync isn't good idea since there are potential problems with it, as reported on this forum.
Even enabling it wouldn't change much if your laptop tends to overheat.
... I find it hard to believe that rebirth could potentially destroy your card by overheating it...
well, you know, best way to 'keep your card safe' is to not turn your laptop ON ... ever  Big Grin

If you getting 200 fps now it basically means that your card can do more than that because 200 is where rebirth is capped - in fact it means that your card is bored during play- it is waiting for cpu most of the time.
If you are gettin between 100 and 200 it means that probably your system+cpu is too weak or overwhelmed by other tasks, it may also happen if your graphic card is using shared memory with cpu (integrated gpu), but in mentioned cases vsync wont help - I have laptop with integrated gpu - it sucks for gaming. Cpu is dual core 1.7GHz but sometimes my fps dropping below 50. There is no remedy except getting decent computer with real graphic card inside.
It is helpful, when reporting a bug, to describe your setup ,hardware and OS.
Reply
#3
using MAXFPS and vsync together doesnt work.

disable the MAXFPS command.
Reply
#4
Well, there are a few things here.

First of all: using "Direct3D overrider" or similiar tools isn't going to do anything, because rebirth is not using D3D at all, but OpenGL. Now I have not much experience with Intel's OpenGL drivers on windows. I heard a lot of bad things about them, even some V-Sync related issues, but I don't remember anything specific.

You could try to disable "triple buffering" and see if it makes a difference.

Using Vsync to prevent overheating - well, that is a questionable context. However, using it to save energy is quite reasonable. There are also a lot of different opinions on how high the framerate for the game should be. Some people can't live with VSync, while others (including myself) are fine with syncing it to only 60fps. But I don't want to drift into that discussion, here.

@Aqqman: I don't know why you experienced so poor performance with an 1.7GHz dual core laptop and integrated graphics. I can play rebirth fine on some single core 1.2GHz atom with Intel GMA945. And I could play the "original" d1x/d2x versions with my thinkpad from 2002, without ever having fps drop below 60.

@ThugsRook: That is not exactly true. The usage of -maxfps does not disable vsync, but the other way around: when Vsync is turned on (in the game, not considering the driver overrides at all), the -maxfps value is completely ignored by the game.
"Perfection is attained not when there is nothing more to add, but when there is nothing more to remove." -- Antoine de Saint Exupéry
Reply
#5
@derhass
Probably because it is poor integrated chip on board? or poor memory management chipset? hell I wish I knew.
Software build does better though but it's capped at 60 by default (or something ridiculously low) I don't remember.

Quote:  That is not exactly true. The usage of -maxfps does not disable vsync, but the other way around: when Vsync is turned on (in the game, not considering the driver overrides at all), the -maxfps value is completely ignored by the game.
Smile
It behaves differently on different machines.
for example - on my PC (not mentioned earlier laptop) if I enable vsync in the driver (forced ON) and try to disable it in the game - it crashes, or if its disabled in the driver but enabled in the game (before disabling it in the driver) I got 60 fps but it feels different (more like maxfps setting*) then if I attempt to disable it in the game - guess what... crash  Big Grin

*maxfps cap works normal for me while vsync ON produces stuttering.
That scenario also differs slightly with different versions of the gpu driver too  Tongue
It's messed up.

So as long as I don't attempt to use vsync it works pretty much the same, doesn't matter which driver I'm using.
Reply
#6
(10-14-2014, 04:03 AM)aqqman link Wrote:It behaves differently on different machines.
for example - on my PC (not mentioned earlier laptop) if I enable vsync in the driver (forced ON) and try to disable it in the game - it crashes, or if its disabled in the driver but enabled in the game (before disabling it in the driver) I got 60 fps but it feels different (more like maxfps setting*) then if I attempt to disable it in the game - guess what... crash  Big Grin
Now, that is basically a driver bug. If I remember correctly, you have some prehistoric ATI/AMD GPU and as such also prehistoric drivers. And the only thing worse than ATI/AMD drivers are outdated ATI/AMD drivers. So you are just screwed. Tongue
"Perfection is attained not when there is nothing more to add, but when there is nothing more to remove." -- Antoine de Saint Exupéry
Reply
#7
(10-13-2014, 04:09 PM)aqqman link Wrote:If you getting 200 fps now it basically means that your card can do more than that because 200 is where rebirth is capped - in fact it means that your card is bored during play- it is waiting for cpu most of the time.
If you are gettin between 100 and 200 it means that probably your system+cpu is too weak or overwhelmed by other tasks, it may also happen if your graphic card is using shared memory with cpu (integrated gpu), but in mentioned cases vsync wont help - I have laptop with integrated gpu - it sucks for gaming. Cpu is dual core 1.7GHz but sometimes my fps dropping below 50. There is no remedy except getting decent computer with real graphic card inside.
It is helpful, when reporting a bug, to describe your setup ,hardware and OS.

My hardware is Intel i3-2330M 2GB memory, Win 7 64-bit. What setup do you mean .ini file? Thanks, but I have a geforce 8800 gt fried because of 100+ fps playing Deadspace. I can live with 60 fps.
I remember I can play Descent shareware back when it first came out in 1995 in my Pentium 133, 16MB of RAM smoothly. Smile Back in the day that was when I was a kid, the first time i got attracted to Descent.
Reply
#8
Well, your cpu is a monster for descent so it should run fine.
You could use software build (classic) its capped low by the code.
lol I've noticed you got 138 fps when close to the wall - with your hardware???? something is really messed up.
setup i meant - fancy stuff in dxx settings,multisampling etc

Dxx rebirth is not even close to Deadspace nor its requirements, but you are right if you have poor cooling or non functional you can burn out your gpu.
I played Descent 1 on 486SX and D2 on Pentium 75MHz - both ran smooth on these machines, back then it was on single threaded operating system without tons of middle-man processes in the background - pure performance.
Rebirth isn't quite there yet.
Reply
#9
It's correct that if you turn ON VSync  in the Rebirth options, it will ignore any setting you give it via -maxfps. So if you toggle OFF VSync in the game, -maxfps argument should work.
But note that -maxfps 60 will not be as accurate as VSync. You will still get tearing.

Now why VSync doesn't work is probably a question to ask the driver. I had good experience with some onboard chips, bad with others - especially when it comes to OpenGL - which Rebirth uses (that's probably why the DirectX tool doesn't help I assume).

And no, aqqman is right - Rebirth has HIGHER requirements than the DOS version. There is basically no assembler code in it (which would make portability and/or maintenance a mess, depending on how you look at it) and some additions like graphical effects do also need their share of your computers performance. That's just how it is. But with a CPU with ~1Ghz you should be fine. The other big influence is the video card. My Intel Onboard chip doesn't reach more then ~130 FPS either. What exactly of a video card is the best choice unfortunately does not only depend on its capabilities but the support of the companies. Rebirth can run on a GeForce 3, probably even less (on Linux I rand the game with an old TNT2 (w/o mutisampling) - no problems). But try and find a (Windows) driver. Especially when it comes to OpenGL support, the support range seems to be very limited and "random" sometimes. However the GF8800 which OP mentioned will do the job fine if proper drivers are used (I think NVidia still supports the card in their mainstream drivers).
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#10
i have tested this issue quite thoroughly on several different machines, with the intel GPU and the nvidia and amd ones.  i have found that intel GPUs, especially older ones (pre i3 age) have major vsync issues.  the best you can do is update your driver to the latest from the INTEL website, not the manufacturers, and cross your fingers it will work.

UNINSTALL THE OLD DRIVER FIRST!!!!

https://downloadcenter.intel.com/Detail_...ldID=23764

about the heating issue... my i7 laptop reaches 80-90 when rendering on CPU (thats why i dont render on it).  unless you look in the vent and there is visible dust infestation, then dont worry about heat.  and this is coming from someone who would be classified as overheat paranoid.  i dont let my desktop GPUs get over 70C.  RealTemp is a neat little program that i use to monitor temps.  MSI Afterburner is another good one for full blown GPU monitoring, fan curve setting, and on screen display stuff.
System IVAN rev 2.0 - Win 7 64bit
Intel i7-3770 4.10 Ghz || EVGA GTX 970 || GSkill Ares 16GB 1600 Mhz || ASUS P8Z77-V LK || Creative Sound Blaster Z || EVGA Supernova P2 850W || Enermax Fulmo Basic

Control Scheme: KEYBOARD DEFAULTS FTW!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)