vsync
#31
another problem you might wanna concider...

DXXR does NOT enduce speedstep/C1E.
so while playing Descent your CPU is constantly clocking up and down, up and down. i cant help but think that this is a very serious problem in of itself!

???
Reply
#32
i have C-States disabled in my bios, and i think on the last page this was brought up.  i think Zico said -noniceFPS switch did something with the CPU idling, but in my tests if i remember right it didnt do anything.  come to think of it, i dont think i have ever seen a difference with that setting, the many times i switch it to trouble shot.  its not hard to kill speedstep/C-states in the bios, its a few levers you need to pull and your good as gold.  CPU-z is the tool i used to make sure it worked.

we need like a new thread for hardware optimizing... :-\
System IVAN rev 2.0 - Win 7 64bit
Intel i7-3770 4.10 Ghz || EVGA GTX 970 || GSkill Ares 16GB 1600 Mhz || ASUS P8Z77-V LK || Creative Sound Blaster Z || EVGA Supernova P2 850W || Enermax Fulmo Basic

Control Scheme: KEYBOARD DEFAULTS FTW!!
Reply
#33
^ we shouldnt need to optimize anything ~ especially c-states.

these are bugs, that need to be fixed.
Reply
#34
(07-14-2014, 02:19 AM)Daedalus link Wrote:im running the latest driver on my GTX 570 and it works perfectly.  there is a way to lock your clock speeds at full to see if that helps using nvidia inspector.

follow this VERY carefully...

http://www.overclock.net/t/1267918/guide...dervolting

I don't know how comfortable I'll be messing with the card's voltage - Wouldn't locking GPU clock speeds at full also be bad for the card over the long term?

In any case, I'm glad you've given me this option at least.
Reply
#35
that looks a bit overly complicated.
the point is to lock the cards c-state, doesnt have to be full speed.

back to vsync...
i dont think the problem IS vsync, i think the problem is vsync @60hz.
@75hz its smooth as butter!  :o


edit: i just checked my GPU clocks in-game  Sad
altho i dont have boost enabled so thats not an issue ~ GPU c-state is dropping back and forth to 2D mode while playing. (not good)
Reply
#36
(07-14-2014, 05:23 AM)ThugsRook link Wrote:that looks a bit overly complicated.
the point is to lock the cards c-state, doesnt have to be full speed.

back to vsync...
i dont think the problem IS vsync, i think the problem is vsync @60hz.
@75hz its smooth as butter!  :o


edit: i just checked my GPU clocks in-game  Sad
altho i dont have boost enabled so thats not an issue ~ GPU c-state is dropping back and forth to 2D mode while playing. (not good)

Well, I would like to get a new monitor soon with a faster refresh rate, but I'm waiting for a decent one that supports G-Sync natively. Maybe that will solve all my stuttering problems with every game.    :-\
Reply
#37
something you guys might wanna try....

EVGA Precision X (for nvidia) has an option called 'framerate target'. i set it for 60 and that seemed to work some miracles. smoother game, no c-state spiking, noticably much smoother explosions!
Reply
#38
(07-14-2014, 05:55 AM)ThugsRook link Wrote:something you guys might wanna try....

EVGA Precision X (for nvidia) has an option called 'framerate target'. i set it for 60 and that seemed to work some miracles. smoother game, no c-state spiking, noticably much smoother explosions!

This seems to have done the job, at least for DXX. Unfortunately it didn't help as much with other games I've been having similar issues with - Stalker doesn't stutter now but using EVGA's Framerate Target results in a lot of erratic CPU activity (now spiking up and down rapidly instead of being locked at 100% load), which I imagine isn't much better for processor health than it was before.

This also didn't give any improvement for Bastion or the other "2D" games where I've been getting sustained 42 FPS and 100% CPU load.

Still, it looks like DXX will work fine with this, so thanks for the tip.
Reply
#39
^ kewl, glad its working for ya Smile

i ran a few more tests with the EVGA program. i set 70fps (even tho im using 60hz vsync) and it seemed to be just a little bit smoother. setting 120fps makes it as bad as it was w/o EVGA program.

cpu and gpu c-states are w/o a doubt part of the problem here.


since Descent is not capable of holding a proper c-state, how is it going to run properly since its frame-based? i think Descent is done until its made tick-based.
Reply
#40
(07-14-2014, 07:06 PM)ThugsRook link Wrote:cpu and gpu c-states are w/o a doubt part of the problem here.
I strongly doubt that. Why do you think so? Going to idle when there is nothing to do is perfectly fine. And spikes from idle to busy is exactly what power management is intended to do. Rush-to-idle is the preferred strategy here, both for CPUs and GPUs.

(07-14-2014, 07:06 PM)ThugsRook link Wrote:since Descent is not capable of holding a proper c-state, how is it going to run properly since its frame-based? i think Descent is done until its made tick-based.
That does not even make sense. "Frame based" vs. "tick based" has nothing to do with this. And "holding a proper c-state" is nothing a software should even attempt to do.

I don't know what is causing the stuttering effect you guys see, but waiting with higher clock frequencies inbetween the stutter occurences is not going to make anything any better.

I think what would be the best strategy is to first find out which operations are acutally causing the delays, so profiling both on CPU and GPU. I could try that in principle, but I can't reproduce the issue on any of the sytstems I have access to.
"Perfection is attained not when there is nothing more to add, but when there is nothing more to remove." -- Antoine de Saint Exupéry
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)