vsync
#21
has any solution been found for this?  ive been pulling my hair out trying to figure it out.

my lenovo y410p laptop (win7) runs d1x and d2x at around 1-5% cpu on 4 cores on fullscreen.  my win7 custom gaming computer hits 100% on one core, fullscreen ONLY(i3-3220; gtx570).  i made sure that all c-states have been disabled (preventing idle frequency drops), which i found it was running in idle mode while in game :o .  however, a MUCH slower XP dell 9200 runs the game in fullscreen at 5-10% cpu on one core.

ill try rolling back a version... or 2.  :-\
System IVAN rev 2.0 - Win 7 64bit
Intel i7-3770 4.10 Ghz || EVGA GTX 970 || GSkill Ares 16GB 1600 Mhz || ASUS P8Z77-V LK || Creative Sound Blaster Z || EVGA Supernova P2 850W || Enermax Fulmo Basic

Control Scheme: KEYBOARD DEFAULTS FTW!!
Reply
#22
I am not able to reproduce this problem, yet. But I would recommend you to get the game back to vanilla state, removing pilots and descent.cfg as well as d*x.ini file. Then try to enable all options you want one by one and see which one causes the issue. You should make sure not to use "-nonicefps" (as this will cause CPU never to idle) and maybe you can temporarily add "-debug" and "-verbose", run the game and then send me the gamelog.txt so I can see if there's something I can make heads or tails of.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#23
Edit: I just noticed Daedalus' post a couple above mine. He has the exact same problem as me. I also ran the game using -debug and -verbose, but I don't know how to get you the gamelog.txt as I am unable to add attachments to my posts.


Both DXX Rebirth games ran fine in version 0.57.3, but since updating to 0.58.1, enabling VSync in the game causes one of my CPU cores to spike to a sustained 100% workload, and I get some pretty bad stuttering as a result. If I play without VSync, CPU behavior is fine (all core activity at 5%), but the lack of a smooth image is not ideal (FPS counter shows 200 in game with VSync off, 59 with VSync on).

I've tried applying various ini options including -nonicefps (makes no difference regardless of VSync setting) and -maxfps (major tearing regardless of rate). I've also tried adjusting every conceivably relevant setting in the nVidia control panel with no change in behavior

I've actually had this same problem in several other games, including Stalker SoC most recently, ever since I started using this computer over a year ago. I haven't been able to find a solution yet.

Here is the hardware I'm using:
Win7 Pro 64-bit SP1
GTX 680 (337.8Cool
60 Hz Acer LCD monitor
i7 3770K @3.5 GHz
16 gigs RAM

I'll take any suggestions. And if someone still has a copy of a pre-0.58 version of DXX Rebirth they can supply, I would also appreciate it.
Reply
#24
All the old source is published, so if you really need an old build, you could make one. Smile

You say that 0.57.3 ran correctly for you, but 0.58.1 fails.  Were both those tests run on the same computer?  Since you report problems with other games, this looks to me more like a problem with your graphics driver than with a specific game.  Have you tried other versions of the nVidia driver?  I recall some users have seen problems where they were able to install a graphics driver that did not work well with their card, but did not refuse to install.
Reply
#25
For nvidia drivers it's also recommended to turn off multithreading for the GPU and setting frames to render ahead to 0. These are settings that can be done in the nvidia driver panel and older versions of the driver DO have issues with that. before doing any of these options, make sure the drivers are updated till the newest version. Then test out the options. If that also fails, try the drivers that came with your graphcis card.

You can also try force VSync via your nvidia driver panel and not via Rebirth itself (leave it off in the game). If THIS also causes high CPU load and shuttering, it's less likely to be a Rebirth problem.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#26
(07-13-2014, 04:33 PM)Kp link Wrote:All the old source is published, so if you really need an old build, you could make one. Smile

You say that 0.57.3 ran correctly for you, but 0.58.1 fails.  Were both those tests run on the same computer?  Since you report problems with other games, this looks to me more like a problem with your graphics driver than with a specific game.  Have you tried other versions of the nVidia driver?  I recall some users have seen problems where they were able to install a graphics driver that did not work well with their card, but did not refuse to install.

Both were run on the same computer. I've kept my nVidia graphics drivers updated since I got the computer about a year and a half ago (a dozen or so different driver versions over that time), and this problem has occurred on all of them, or at least since the release of 0.58.1. I've only been using the official GTX 680 drivers from nVidia.

I'm not knowledgeable enough to know how to compile a build myself from the source. Is there not an old zip of 0.57.3 out there somewhere? I've done a search but all previous versions of the game seem to have disappeared from the internet.

Or if you can teach me how to compile in a forum post, I would try that as well.


(07-13-2014, 05:26 PM)zico link Wrote:For nvidia drivers it's also recommended to turn off multithreading for the GPU and setting frames to render ahead to 0. These are settings that can be done in the nvidia driver panel and older versions of the driver DO have issues with that. before doing any of these options, make sure the drivers are updated till the newest version. Then test out the options. If that also fails, try the drivers that came with your graphcis card.

You can also try force VSync via your nvidia driver panel and not via Rebirth itself (leave it off in the game). If THIS also causes high CPU load and shuttering, it's less likely to be a Rebirth problem.

Strangely enough, turning off VSync in-game and forcing it on through the nVidia control panel did result in an improvement, in that my CPU behavior was now normal (not spiked). However, the game still had its stuttering problem. The stuttering is not persistent - it is most common when opening doors, firing flares, and when enemies explode (not 100% of the time on these occasions, though) - but it is bad enough to not want to bother with VSync.

I also tried setting "maximum pre-rendered frames" to 1 (there is no option for 0 - is that what you meant?), which has helped in some other games with a similar stuttering problem (Pinball FX2 and Sigma Team's Alien/Zombie "Shooter" series), but here it did not help.

I also tried toggling triple buffering, threaded optimization both on and off, as well as switching Power management from 'adaptive' to 'prefer maximum performance', and trying every available option for 'multi-display/mixed-GPU acceleration'. None of these has removed the stuttering.

I'm hesitant to try rolling back to an earlier driver, because I've had other problems related to PhysX that recently required a full driver uninstall and reinstall that I'm not eager to repeat. If I'm unable to solve this problem with Rebirth, I'll probably just put it away and try it again in a future release.
Reply
#27
Flang, i sent you a PM regarding this thread.

there is no way to rid of the stuttering issues, i have tried to solve this using every technique i know on the 2 laptops that have this issue and i settled with leaving vsync off.  this occurred on an older XP laptop running OpenGL 2.1.8xxx and a brand new Win7 64bit gaming laptop using the integrated intel graphics running OpenGL version 4.2(but the Nvidia GT 755M works).  all power settings configured to maximum performance, im pretty tech savy and im ready to pull my hair out.

i have to ask this, are you sure your card isnt getting too hot?  that is one beast of a card you got there and it needs good cooling.  i have been the unfortunate witness to more then one GFX card dying of heat exhaustion.  MSI Afterburner is the program i use to monitor my GTX 570, it will also let you know if the card is running in low power mode, which it likely will unless you have it set to Maximum Performance in the Nvidia Control Panel.  even still i have heard the newer cards adjust power modes on the fly causing massive performance loss.
System IVAN rev 2.0 - Win 7 64bit
Intel i7-3770 4.10 Ghz || EVGA GTX 970 || GSkill Ares 16GB 1600 Mhz || ASUS P8Z77-V LK || Creative Sound Blaster Z || EVGA Supernova P2 850W || Enermax Fulmo Basic

Control Scheme: KEYBOARD DEFAULTS FTW!!
Reply
#28
Alright, so I tried the game using 0.57.3, and the stuttering/CPU problems are still there. Since this version worked fine for me 6 months or so ago, I don't think the problem is caused by the game, but by a more recent nVidia driver or maybe something else that got installed on my machine during that time.

As far as GPU overheating goes, I don't think it's an issue. I checked using nVidia Inspector and everything is staying nice and cool while running DXX - temp stable at around 36 C, fan level at 30%.
Reply
#29
Compiling an old version might work with the zif toolkit, but I cannot help with that.  However, it sounds like you found the right version through other means, so that does not matter now.

Although your problem runs deeper, I am glad to see this is not an issue in the Rebirth code.
Reply
#30
im running the latest driver on my GTX 570 and it works perfectly.  there is a way to lock your clock speeds at full to see if that helps using nvidia inspector.

follow this VERY carefully...

http://www.overclock.net/t/1267918/guide...dervolting

in summary, paste the code below into a (right-click new text document) file and save it as a .BAT file.  USE AT  YOUR OWN RISK!  just be sure to put the bat in the NV inspector folder  Wink

this worked on my computer and according to the article its a global system.  if in the rare event it gives you a black screen, just reboot, no harm was done to the card.

Code:
nvidiaInspector.exe -forcepstate:0,0

reboot the computer to restore defaults or use 0,16 at the end of the bat file.

for all you ATI/AMD users out there, there is a different, but unfortunately more difficult, method of achieving a similar result.  its more limited and a hair more on the risky side.  my HD5770 seemed to take my mess ups like a man though.  if your interested PM me, i dont want to derail this thread anymore.
System IVAN rev 2.0 - Win 7 64bit
Intel i7-3770 4.10 Ghz || EVGA GTX 970 || GSkill Ares 16GB 1600 Mhz || ASUS P8Z77-V LK || Creative Sound Blaster Z || EVGA Supernova P2 850W || Enermax Fulmo Basic

Control Scheme: KEYBOARD DEFAULTS FTW!!
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)