[D*XR 0.57.3, Windows 7] CD audio bug still isn't fixed
#11
This is really odd indeed.

I have run so many more tests so far but I simply cannot reproduce this. This issue is still on my list and while working on the game on the past months I always had one CD in the drive and was pretty much all the time checking this out. So what I want to say: Bear with me, this isn't easy to debug since it simply doesn't occur on my end and the code itself also doesn't look bugged as well.

But if I may ask: If you have the Mac CD, how do you play this on XP? I thought the Mac CDs have their own filesystem that cannot be read on XP? Not sure about the Audio tracks tho. I don't have a Mac CD version of the game so I cannot test that myself.

Also I try to get my hands on a XP version once more to set it up via VirtualBox or something so I can test with that, too. Maybe SDL is reporting the wrong number of tracks on the disc... That could at least explain some things. Otherwise I gotta implement some more debugging output so you guys who experience this problem can send me logs that will hopefully help me to identify the reason behind this.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#12
my D1 MACplay audio CD is home made, using "Mixed-Mode". (data+audio)

Redbook works fine for me in other games using this method.


Quote:Maybe SDL is reporting the wrong number of tracks on the disc... That could at least explain some things.
ill have to check that... i put an extra track on the disc.
i dont think any of the other discs i tried had 14 tracks either, so i should re-test with a 14 track CD.



EDIT: nope, 14 track cd didnt work.
Reply
#13
I mean it may be that SDL probably just reports 1 track at all. Not sure why this bug would happen otherwise. As said, the code itself works fine. I have the feeling that there's more behind this.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#14
update:

when the CDA track stops looping it does appear to be trying to access the disc and it makes the game very "choppy", and eventually unplayable.
its as if its trying to access Track01 (the data track) which of course it cant.

everything else about CDA playback/options seems to work just fine, just "1 track per level" is broken.

gonna try a few more experiments today.



EDIT: yup! that fixed it! Big Grin ~ DO NOT use mixed mode CDs.
this means CDs with data+audio on them... like the game discs.

zico: the game is trying to play track01!



EDIT2: new bug ~ CD audio volume control does not work.


the only thing left for me to check is the MAC CD order option.
Reply
#15
Alright so if this is actually a problem with mixed mode, this is probably a Windows-SDL bug since I  am pretty sure I *HAVE* tested a lot of the original game CDs which are all mixed mode.

Also about the Volume control: Yes, this does not work since SDL itself does not support it. On Linux we have a way around this but there the whole thing is analog. So no sound cable, no music at all. It's time SDL HEAVILY updates the whole CD Audio. Even tho I highly doubt it since digital Music is used much more frequently and you can pretty much emulate the CD Audio behaviour with the Jukebox.

So I'm gonna doublecheck with some more mixed mode CDs and if that works I can't do much more than to report this issue to the SDL developers and close this one right here.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#16
(03-23-2013, 06:06 PM)ThugsRook link Wrote:the only thing left for me to check is the MAC CD order option.
nope, MAC CD order option still doesnt work, even with a correctly built 14 track audio CD.


zico: you should disable the endlevel CDA music flag, it really doesnt work well at all with D1 PC. just let the level music play on, like in jukebox mode.
Reply
#17
The "force MAC CD order" option basically  only disables the CD validation and guesses the original play order to it.
Without this option and a genuine Audio CD, every track is played for levels and continously instead of repeating songs. So if you made a CD with the original track order by yourself you'd need this option 100% as the game would be unable to recognize it by itself.

If this option also does nothing, then the bug you have is not only restricted to Mixed Mode CDs but the SDL Redbook layer has much more problems than I thought.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#18
MAC Order doesnt work at all.

track looping works, but it has to be a "real audio CD". (no data track)

it is w/o a doubt playing track01, see above ^


Jukebox or .SNG addon is a wayyyyyyyyy better option.
honestly, you can delete Redbook support at this point Wink


in-game... i play the MIDIs  Cool
(but its nice to have options)
Reply
#19
I'll check out all the observations before the next release ... can't say what exactly is wrong.

But I agree: Jukebox or Soundtrack Sets themselves are - in the long run - the way better option. That it until SDL devs will improve upon CDA support (finally digital Audio on Linux, builtin volume control, etc).
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply
#20
Doublepost but I wanna give an update on that:
I have no added a lot of verbose-output to the Redbook code. So if you run the upcoming 0.58 with "-verbose" the log will list basically every action the code does. It'll list the tracks recognized, which tracks are queued, when the repeat function is called and so forth. With this output I might be able to see what's wrong on your end.
The greatest pleasure in life is to do what people say you cannot do.
Uhm... Honey, there's a head in the toilet!
Reply


Forum Jump:


Users browsing this thread: 2 Guest(s)