[d1x/d2x 0.60 beta 2 - Windows] Game won't launch
#1
I've followed install instructions. Both D1 and D2 have necessary GOG files copied over. My GOG versions launch in DOSBOX and work fine.

Windows 10 x64 bit
Nvidia GTX 1080

There is nothing in stderr.txt nor stdout.txt. Launching from a command line, there is no output. It just never really launches. Turning on options for -debug -verbose and even -safelog do nothing.

Neither d1x-rebirth.exe nor d2x-rebirth.exe will launch. Compatibility options in Windows 10 don't help either.

Threads here:

https://forum.dxx-rebirth.com/archive/in...d-877.html

and here:

https://www.mtbs3d.com/phpbb/viewtopic.php?f=3&t=14979

Suggest you may need a replacement opengl32.dll file in the folder, but neither work. And I have a device with working OpenGL (Nvidia GTX 1080 with the latest drivers)

But even the NoGL versions (d1x-rebirth-nogl) won't launch, so it doesn't appear to have to do with OpenGL.

This is what appears in the Windows Event Viewer:

Faulting application name: d1x-rebirth.exe, version: 0.0.0.0, time stamp: 0x5ad29161
Faulting module name: ntdll.dll, version: 10.0.17754.1, time stamp: 0xcee84e63
Exception code: 0xc0000005
Fault offset: 0x0004f1e5
Faulting process id: 0xa794
Faulting application start time: 0x01d44e2b8914dff8
Faulting application path: D:\Games\D1X-Rebirth\d1x-rebirth.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: f8874862-b2e4-4eab-a92b-6240c46a87fe
Faulting package full name: 
Faulting package-relative application ID:
Reply
#2
d1x-rebirth_v0.58.1-win however launches just fine.
Reply
#3
Thank you for providing the Windows Event Viewer data. As I read that, it is blaming a system library (ntdll.dll) for an invalid memory access. Unfortunately, there is nothing I can do about it with the information provided. Such crashes in ntdll.dll are usually an indication of memory corruption elsewhere, which only became fatal when ntdll.dll tried to use the corrupted memory. Unless you can trace the memory corruption to its source, I cannot fix the source (and the source may not even be under my control, if it comes from some other library on your system, such as your graphics driver). At this point, all I can offer is that other people have run the game without this problem, from that build. Presumably, some of them are on Windows 10.

Have you ever run that build successfully on any Window 10 machine? If so, how do the systems differ? Can you reboot into a different version of Windows and test whether the game runs there?

[This response cross-posted to issue you opened on Github. There's no need to post so many places. I read them all.]
Reply
#4
I'll try on another Windows 10 machine, but I was looking to get started with Descent (never played it before).

0.60 beta 2 was the first version I tried. Then I went back to 0.58 and that one launches just fine.

I've rebooted and tried 0.60 beta 2 again, and still nothing.
Reply
#5
Yes, it's weird that the older one launches fine. There are extensive changes between those builds, but none that I would expect to matter here. I'm not the one who built any of those though. You'd need to ask AFP about 0.60-beta2. I don't recall who built 0.58.1.

I'd suggest also trying a Windows machine that is not Windows 10, as well as try a Windows 10 of a different patch level. As the GOG page says for all their Windows games:
Code:
Please be advised that Windows 10 operating system will receive frequent hardware driver and software updates following its release; this may affect game compatibility
I don't test on Windows 10 at all.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)