Update
#1
I backported a batch of fixes to stable-0.60.x, including one fix for a remotely exploitable security issue (stack buffer overrun due to ill-formed tracker message). This bug was added with the new tracker in December 2016. I remember flagging a security problem in one of the code reviews, but somehow this one was never fixed. All users should upgrade.

Highlights:
- Fixed tracker security bug
- Added tracker NAT hole punch notice dialog
- Fixed handling missions that explicitly set a blank briefing
- Fixed crash on using Descent 1 with some missions that have too many blown bitmaps

Also, I bumped the Gentoo ebuild to the current patch level. If anyone maintains build systems for other distributions, please submit them and I will attempt to keep those current, too.
Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)