Beta 2 XP Coop Bug
In the Windows XP build of D2X-R Beta 2, every time I run a coop game, I hit start and get a black screen while everyone else enters the level. They get the message that the host left the game and are kicked out. Then I am allowed into the level.

I have gotten consistent results across every mission I've tried. This isn't limited to game starts either - this happens at the start of every level.
Does this also affect other builds? What about other platforms? Linux/amd64 current tip (which admittedly is not the same source base you used) seems fine here. I'm not set up to play Windows builds. I don't think anything has changed in tip that would fix this problem though.

Do you have the tracker enabled? If yes, does disabling it help?
It's not enabled. Beta 2 XP is the only one that I've ever had this issue with - Beta 1 caused no issues and all nightlies and weeklies refused to start anyway.
Beta 1 (Dec 11 2016) and Beta 2 (Apr 15 2018) are 852 commits and ~489 days apart. That would still not be too bad for me to test locally, if I could reproduce the problem. I cannot reproduce the problem.

I mostly avoid dealing with the netgame code, so I don't have any good leads on this. Is Beta 2 non-XP affected? If someone else hosts using the Beta 2 XP build, while not actually on Windows XP, do they report the same problem? What, if anything, do you do while sitting at the black screen? Does it progress simply through timeout? Do you get any other messages before the black screen ends? What is the game doing during the time that the screen is black?
It simply progresses through the timeout. Nothing happens during the black screen. I have no way of knowing what the game is doing. We can't really test with non-XP OS or build.

I did discover that loading a savegame will cause the joinee to have the "waiting for signal from host" message until I join, so I think that my computer is having a hard time connecting.

Most recently, the joinee got an error that I failed to send important packets. This happened once or twice, but not regularly.
As a wild guess, run the game with -debug and pastebin the debug log. I don't expect that to show much useful information, but if you cannot test any of the other configurations, I have nothing else to try.
Turns out every time the joinee gets a "failed to send important packets" message.

Forum Jump:

Users browsing this thread: 2 Guest(s)