DXX-Rebirth Forum

Full Version: [DXXR v0.57.3 Windows 8] 4x multisampling causes energy gauge artifacts
You're currently viewing a stripped down version of our content. View the full version with proper formatting.
Pages: 1 2
Game: D1XR and D2XR v0.57.3 and newer (I tested all versions from v0.55.1 to v0.58.1.)
OS: Windows 8 64-bit
Video card: Nvidia GeForce GTX 660M
Display: 1366 x 768 laptop, 1920 x 1080 TV (The bug affects both.)

Screenshot: d2xr-v0.57.3-in-game-4x-msaa.png

With 4x multisampling enabled at certain resolutions, I can see some minor visual artifacts on the energy gauges. This is most visible in cockpit mode; status bar mode only shows a subtle, colored rim around the energy and afterburner gauges (yellow on energy, red on afterburner). The bug seems to occur only when the game's window height is 900 or less. Both fullscreen and window mode are affected.

These resolutions show the bug:

1600 x 900
1440 x 900
1366 x 768
1360 x 768
1280 x 800
1280 x 768
1280 x 720
1280 x 600
1152 x 864
1024 x 768
800 x 600
720 x 480
640 x 480
640 x 400
512 x 384
400 x 300
320 x 240
320 x 200

These resolutions do not show the bug:

1920 x 1080
1680 x 1050
1600 x 1200
1400 x 1050
1280 x 1024
1280 x 960
What's your native resolution and are you using flat panel scaling with fixed aspect ratio from inside the nvidia control panels 3d settings? Curious!
(11-07-2013, 03:23 AM)BUBBALOU link Wrote:What's your native resolution and are you using flat panel scaling with fixed aspect ratio from inside the nvidia control panels 3d settings? Curious!

Native resolution is 1366 x 768 when I use my laptop's display, and 1920 x 1080 when I use the TV. (I added that info to the original post now.) I don't see those options in the NVIDIA Control Panel … I seem to lack many of the options other people have; even my parents' GeForce GT 525M-equipped laptop has more options available.
(11-07-2013, 06:46 AM)Ryusei117 link Wrote:Native resolution is 1366 x 768 when I use my laptop's display, and 1920 x 1080 when I use the TV. (I added that info to the original post now.) I don't see those options in the NVIDIA Control Panel … I seem to lack many of the options other people have; even my parents' GeForce GT 525M-equipped laptop has more options available.
that sucks, is it a locked PC OEM driver, where the MFG has their own special model number?
(11-09-2013, 03:35 AM)BUBBALOU link Wrote:that sucks, is it a locked PC OEM driver, where the MFG has their own special model number?

Not as far as I can tell … My laptop came with a preinstalled video card driver, but I've since updated it with the usual drivers from Nvidia's website. I currently have the latest driver: the "GeForce R331 Game Ready Driver - WHQL", version 331.65.
I will see what I can do about it. Making the energy bar empty is actually a little trick that isn't as fancy as one may think. Yeah, you just paint black over it. We are in 2013 but we still use the old tricks. Smile
The resolution itself is a little odd one (not that there's anything wrong with that) and the game might do some rounding errors here. I'll see what I can do about it.
I don't know if this detail is important, but the bug wasn't present in v0.57.2. Do you remember any changes between that version and v0.57.3 that could be relevant to this bug?

(12-10-2013, 08:48 PM)zico link Wrote:Making the energy bar empty is actually a little trick that isn't as fancy as one may think. Yeah, you just paint black over it. We are in 2013 but we still use the old tricks. Smile

Dang it, now I'm never gonna see the energy bars the same way again … Tongue
Thanks for letting me know. I will compare that when fixing. Well since Descent has some very limited 2D drawing functions this is more or less a series of lines with different lengths so you can make the sides slanted like that. Possible that there were some little changes with these functions. But on that note since this bug is caused by interpolation of Multisampling, you might be able to work around it by turning Multisample off in DXX and go to your nVidia control panel and just force another FSAA method on the game. This could at least help you till I got this one addressed "ingame". Smile
Oh, check this out … I disabled the in-game 4x MSAA, and tried several other anti-aliasing methods from NVIDIA Control Panel, one at a time. Many of them actually caused the same artifacts as the in-game option.

Don't worry, I'm that guy who's perfectly happy using nostalgia mode while this is being fixed. Wink
fxaa is fake anti aliasing, its a post processed effect. You will not see the glitch there, but msaa and csaa are true anti aliasing. (aka they scale the whole viewport by a factor of 2 or 4)
Pages: 1 2